广告位联系109626141@qq.com

思科路由器设置

查看路由器端口:

Router#show ip int bri

 

静态路由,必须在对方路由器上设置回程路由

Router(config)#int g0/0

Router(config-if)#ip address 172.16.1.1255.255.255.252

Router(config-if)#no shut

Router(config-if)#int g0/1

Router(config-if)#ip address 192.168.10.1255.255.255.0

Router(config-if)#no shut

Router(config)#ip rout 192.168.0.0255.255.0.0 172.16.1.2

 

查看路由表:

Router#show ip route

 

删除动态路由表:

Router#clear ip route *

 

NAPT配置:

Router(config)#int g0/0

Router(config-if)#ip nat inside

Router(config-if)#int g0/1

Router(config-if)#ip nat outside

Router(config)#ip nat pool naptout60.210.40.10 60.210.40.10 netmask 255.255.255.252

Router(config)#access-list 1 permit192.168.0.0 0.0.255.255

Router(config)#ip nat inside source list 1pool naptout overload 

思科交换机设置

查看端口:

Switch>show ip interface brief

 

查看当前配置:

Switch>enable

Switch#show running-config

 

修改交换机名字:

Switch#config terminal

Switch(config)#hostname abc

abc(config)#

 

返回上一层:exit

返回特权模式:ctrl+z 

 

保存配置:

Switch#copy running-config startup-config  或者Switch#write

 

创建VLAN

Switch#vlan database

Switch(vlan)#vlan 10 name abc

 

查看VLAN:

Switch#show vlan

 

删除VLAN:

Switch(config)#no vlan 10

 

将某个端口加入VLAN:

Switch(config)#int f0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

 

将一组端口加入VLAN:

Switch(config)#int range f0/2-4

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport accessvlan 10

 

查看VLAN摘要:

Switch#show vlan brief

 

查看指定VLAN信息:

Switch#show vlan id 10

 

配置trunk端口:

Switch(config)#int g0/1

Switch(config-if)#switchport trunkencapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)#switch trunk allowed vlanall

 

查看端口状态:

Switch#show int f0/2 switchport

 

给三层交换机VLAN设置IP:

Switch(config)#int vlan 20

Switch(config-if)#ip add 192.168.2.254255.255.255.0

 

查看VLAN接口信息:

Switch#show int vlan 10

 

启用路由三层互通:

Switch(config)#ip routing

 

交换机配置ACL访问控制列表:

Switch(config)#access-list 1 deny192.168.1.0

Switch(config-if)#int vlan 10  (进入vlan接口)

Switch(config-if)#ip access-group 1 in

 

显示ACL:

Switch#show access-lists

 

删除ACL:

Switch(config)#no access-list 1

 

VTP配置(服务端):

Switch(config)#vtp domain gvt

Switch(config)#vtp mode server

 

VTP配置(客户端):

Switch(config)#vtp domain gvt

Switch(config)#vtp mode client

 

恢复出厂设置:

Switch#write erase

Switch#reload

基础知识

一、在引用调用方式下进行函数调用,是将实参的地址传递给形参

二、路由器连接帧中继网络的接口是Serial接口,连接双绞线以太网接口的是RJ-45接口。

三、海明码是一种纠错编码,一对有效码字之间的海明距离是两个码字之间不同的比特数

四、IPV4的D类地址是组播地址,用作组播标识符,其中224.0.0.1代表本地子网中的所有主机,224.0.0.2代表所有路由器,224.0.0.5代表OSPF路由器。

五、ICMP协议属于网络层协议,ICMP协议数据单元封装在IP数据报中。

TXT文本转XML再转EXCEL的相关处理

一、将多个文本文件合并为一个文件

在CMD命令提示符下,输入以下命令:

type *.txt >>f:\111.txt

说明:可以将多个TXT文本文件,合并为一个文本文件。

 

二、XML文件格式

 

<?xml version="1.0" encoding="utf-8" ?> 

<ITEM>

<A></A>

<A></A>

<A></A>

</ITEM>

 

三、Uedit32的操作

 

1、删除指定字符串的文本所在的行

 

%*指定字符串*^p  正则表达式 替换为空  

 

2、行首行尾添加字符串

行尾^p替换为</A>^p

 

行首^p替换为^p<A>

 

四、EXCEL的操作

数据–自其它来源–来自XML数据导入

 

以上方法有不当之处请指出。

网络知识

IPV6地址分为单播地址、组播地址和任意播地址。

单播地址分为:

1、可聚合全球单播地址;

相当于IPV4的公用地址。格式前缀为001

2、链路本地地址;

相当于IPV4的自动专用地址,格式前缀为1111 1110 10

3、站点本地地址;

相当于IPV4中的私网地址,格式前缀为1111 1110 111

4、其他特殊单播地址

组播地址:

格式前缀为1111 1111

任意播地址:

可以作为目标地址,只能分配给路由器。

 

BGP–Open报文,TCP:179; 

OSPF–Hello报文;

RIPV2:触发更新、子网聚合、组播、散列口令

EXCEL不能删除行列的解决

使用excel的朋友在编辑表格时,会出现行列不能删除的问题,甚至重新安装都不行。

 

解决方法:

 

将“C:\Documents and Settings\Administrator\Application Data\Microsoft\Excel ”复制到我的电脑的地址栏里面,然后点击“enter”。找到 Excel11.xlb删除(2007版本,删除 Excel12.xlb;2010版本,删除 Excel14.xlb)【假如没有找到,点击导航栏,工具——文件夹选项——查看——显示所有文件和文件夹——确定

基础知识

1、在程序执行过程中,Cache与主存的地址映像由硬件自动完成

2、指令寄存器的位数取决于指令字长

3、若某计算机字长32位,内存容量2GB,按字节编址,则可寻址范围为512MB。(2G*8/32=512MB)

4、视频信息是连续的图像序列,是构成视频信息的基本单元。

5、为了说明某一问题,在学术论文中论文中需要引用某些资料。可以引用发表的作品,不能引用未发表的作品。

6、在程序运行过程中,常使用参数在函数间传递信息,引用调用传递的是实参的地址

7、常用的虚拟存储器由主存–辅存两级存储器组成。

8、中断向量可提供中断服务程序的入口地址

9、为了实现多级中断,使用堆栈来保护断点和现场最有效。

10、DMA(直接内存访问模式)工作方式下,在主存和外设之间建立直接的数据通信。

VTP与STP

VTP(Vlan Trunk Protocol)即VLAN干道协议,有三种模式:

VTP Server—初始状态

VTP Client

VTP Transparent

VTP信息只能在Trunk端口上传播,共享相同的VLAN数据库的交换机构成一个VTP管理域。


 

划分VLAN的最主要目的是抑制广播风暴。

VLAN ID用12位表示,即数值范围为1-4096。其中,1-1005是交换机支持的标准范围。

传输层协议之TCP与UDP

在网络设置中,我们经常听说TCP/IP协议属性。其实IP属于第三层网络层的协议,而

TCP(传输控制协议),是一个面向连接的协议,提供双向的、可靠的、有流量控制的字节流的服务。

面向连接是指一次正常的TCP传输需要通过在TCP服务端建立特定的虚电路连接来完成,该过程通常被成为“三次握手”。

基于TCP的应用层协议有:SMTP(25)、FTP(21)、HTTP(80)、TELNET(23)、POP(110)。

采用端口号来区分不用的应用进程。为各种公共服务保留的端口号是1-1023。

TCP实体发出连接请求SYN后,等待对方的SYN,ACK响应。

TCP段头的最小长度是20字节。

顺序号包含在TCP头中而不包含在UDP头中。

TCP使用可变大小的滑动窗口协议来进行流量控制。

 

UDP即用户数据报协议,是一个无连接服务的协议。基于UDP的应用层协议有:SNMP、DNS、TFTP、DHCP、RPC。

IP地址的计算

一、根据IP地址计算网络地址、广播地址;

二、根据子网位数(掩码)计算可容纳的主机数;

三、根据网络地址划分子网;

某交换机划分了VLAN,并且设置这个VLAN的地址为:10.200.55.253,子网掩码255.255.252.0

255=11111111 ;  252=11111100,

子网掩码转换为二进制为:11111111.11111111.11111100.00000000

所以上面的地址可以写作: 10.200.55.253/22(说明:22=8+8+6)

网络地址的运算:IP地址与子网掩码“与”运算。

55=110111=00110111; 253=11111101

   10.200.00110111.11111101

255.255.11111100.00000000

通过上面的与运算得到网络地址:10.200.00110100.00000000,十进制:10.200.52.0

二进制转换十进制的运算如下:

00110100=110100=2的(6-1)次方+2的(5-1)次方+2的(3-1)次方=32+16+4=52

网络地址:10.200.00110100.00000000,前面的22为是网络位,后面的10为是主机位,可以容纳的主机数量为:2的10次方-1=1024-2=1022台。

广播地址即主机位全为1:10.200.00110111.11111111,转换为十进制:10.200.55.255

二进制转换十进制的运算如下:

00110111=2的5次方+2的4次方+2的次方+2的1次方+2的0次方=32+16+4+2=55

如果将网络10.200.52.0/22,划分为8个子网,需要向主机位借位。借1位=2的1次方=2个子网;借2位=2的2次方=4个子网;借3位=2的3次方=8个子网,以此类推。

网络10.200.52.0/22,向主机位借3位就可以划分为8个子网,即网络位25位(子网掩码255.255.255.128),主机位32-25=7(可以容纳2的7次方-2=126台主机)

子网,          有效的主机   ,         广播地址

10.200.52.0,   10.200.52.1到10.200.52.126,     10.200.52.127

10.200.52.128, 10.200.52.129到10.200.52.254,   10.200.52.255  

10.200.53.0 ,  10.200.53.1  到 10.200.53.126,   10.200.53.127  

10.200.53.128 ,10.200.53.129  到 10.200.53.254, 10.200.53.255  

10.200.54.0,   10.200.54.1  到 10.200.54.126,   10.200.54.127

10.200.54.128, 10.200.54.129  到 10.200.54.254, 10.200.54.255  

10.200.55.0,   10.200.55.1  到 10.200.55.126,   10.200.55.127  

10.200.55.128, 10.200.55.129到 10.200.55.254 , 10.200.55.255